New Incident Affecting Gett's Platform

Incident Report for Gett

Resolved

The issue has now been resolved.
Posted Dec 12, 2025 - 13:22 UTC

Investigating

We have received reports of issues with order creation. This may impact your ability to book or edit rides via the Gett app and/or web portal. We are currently looking into this and will update on our progress to resolve this issue.
Posted Dec 12, 2025 - 13:07 UTC